Adding HDAUDIO device bus support to WinPE 2.x

Posted: 01-23-2009, 07:20 AM
Hi all,

How would I go about configuring WinPE 2.x to recognise devices on the
HDAUDIO\ bus? At the moment I've scripted a batch with a WMI query
which converts the SUBSYS substring in the PCI\* deviceID and then
searches for that string in a list of driver .INF files - which works
for sound devices on the HDAUDIO bus, but not Modem devices. WinPE
enumerating HDAUDIO\ devices (like XP+KB888111 or XP SP3/Vista) would
be ideal.

Is this a known issue? Has it been brought up before? Will it be
addressed in later editions of WinPE?

Cheers all,
DMcG

Adding HDAUDIO device bus support to WinPE 2.x


Responses to "Adding HDAUDIO device bus support to WinPE 2.x"

deemacgee
Guest
Posts: n/a
 
Re: Adding HDAUDIO device bus support to WinPE 2.x
Posted: 01-27-2009, 01:52 AM
Never mind, found the problem: WMIC doesn't list the the HDAUDIO\*
class (at all? By default? I don't know yet.)
Workaround: use the devcon utility. The scan command I'm using now is:

devconi386.exe findall HDAUDIO*

Works a charm.

On Jan 23, 6:20*pm, deemacgee <deemac...@gmail.com> wrote:
> Hi all,
>
> How would I go about configuring WinPE 2.x to recognise devices on the
> HDAUDIO\ bus? At the moment I've scripted a batch with a WMI query
> which converts the SUBSYS substring in the PCI\* deviceID and then
> searches for that string in a list of driver .INF files - which works
> for sound devices on the HDAUDIO bus, but not Modem devices. WinPE
> enumerating HDAUDIO\ devices (like XP+KB888111 or XP SP3/Vista) would
> be ideal.
>
> Is this a known issue? Has it been brought up before? Will it be
> addressed in later editions of WinPE?
>
> Cheers all,
> DMcG
 
LinkBack Thread Tools Display Modes
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
MDAC 2.8 support in WinPE 2004 (sp2) René Windows XP Setup 4 01-18-2005 09:43 PM
WinPE and adding a Driver KM Windows XP Embedded 0 06-02-2004 07:15 PM
Adding support for a PCMCIA device Thomas Johansen Windows XP Embedded 7 01-21-2004 11:50 AM
Adding Additional Netword Card Support to WinPE Matt Hendrix [MSFT] Windows XP Setup 0 11-17-2003 03:53 PM
Adding components to WinPE Louis.Dawson Windows XP Setup 0 07-15-2003 11:31 AM