Cannot delete desktop folder

Posted: 03-08-2008, 09:58 AM
I have Vista on my laptop. I copied a folder on my (Windows XP) desktop onto
a CD and from there onto my laptop desktop. I cannot now delete that folder,
as I am told I need permission. How do I give myself permission, please?

Cannot delete desktop folder


Responses to "Cannot delete desktop folder"

Guest
Posts: n/a
 
Re: Cannot delete desktop folder
Posted: 03-09-2008, 01:24 AM
you will need to have admin priv to delete it. You can try to take ownership
of the file first. If that dont work try this.

start/all programs/ admin tools/ local security policies.
Expand local policies and select security options, scroll down to the end of
the list and double click "Behavior of The Elevation Prompt For Admin In
Approval Mode"
from the drop down list select "elevate without prompting, and click ok

"Blackbeard" <Blackbeard@discussions.microsoft.com> wrote in message
news:53377032-034C-4813-94A6-B6585E84055A@microsoft.com...
>I have Vista on my laptop. I copied a folder on my (Windows XP) desktop
>onto
> a CD and from there onto my laptop desktop. I cannot now delete that
> folder,
> as I am told I need permission. How do I give myself permission, please?
Blackbeard
Guest
Posts: n/a
 
Re: Cannot delete desktop folder
Posted: 03-09-2008, 08:57 AM
Thank you Matthew, but you say I should take ownership of the file. But how
do I do that?

As I don’t know how to do that, I tried your second solution, but
“"Behaviour of The Elevation Prompt For Admin In Approval Mode" does not
exist in the drop down list you suggested.

I am the sole user, and the Administrator for, this PC. Why on earth can’t
I just delete a desktop folder?

Jeff Smith [MSFT]
Guest
Posts: n/a
 
Re: Cannot delete desktop folder
Posted: 03-09-2008, 12:31 PM
There are actually several possible reasons that you cannot delete the
folder. Here are a few things you can try:

1) Since it was copied off a CD, it might have the "Read-only" property
set. Right-click on the folder, choose Properties, clear the "Read-only"
checkbox, and click OK. Try deleting it.

2) Sometimes, Windows will give that error if another program is using a
folder. (Are any background programs using the folder? Sometimes files
sharing or jukebox programs grab folders and don't let go of them.) Reboot
your computer and try deleting it first thing when it loads up again.
(Rebooting your computer in "Safe mode" is a more extreme way of making sure
a minimal set of programs are running).

3) Right-click on the folder, choose Properties, click the "Security" tab
[note: not all editions of Windows Vista support this tab -- if you don't
have it, skip this step]. Click the Advanced button, and on the new window
that pops up, click the "Owner" tab. Click the Edit button and highlight
your user account in the list. Check the "Replace owner on subcontainers..."
checkbox, and click OK. (You might have to wait a few seconds). Click OK on
all the windows, and try deleting the folder again.

4) Follow the steps above to get to the Security tab, then click the
Advanced button again. On the "Permissions" tab, click the "Edit..." button.
Make sure that "Include inheritable..." checkbox is clear (choose 'copy'
button if it asks you). Make sure that the "Replace all..." checkbox is
checked. Highlight your user account name, click the new "Edit..." button,
check the checkbox in the "Full control" row, under the "Allow" column.
(Make sure there's no Deny entries). Click OK on all the windows.

Of course, if you get any strange errors during these steps, post them here
and we'll try to figure them out.


"Blackbeard" wrote:
> Thank you Matthew, but you say I should take ownership of the file. But how
> do I do that?
>
> As I don’t know how to do that, I tried your second solution, but
> “"Behaviour of The Elevation Prompt For Admin In Approval Mode" does not
> exist in the drop down list you suggested.
>
> I am the sole user, and the Administrator for, this PC. Why on earth can’t
> I just delete a desktop folder?
>
Blackbeard
Guest
Posts: n/a
 
Re: Cannot delete desktop folder
Posted: 03-09-2008, 03:26 PM
Many thanks for your suggestions, Jeff. I have carefully followed them all,
but none has worked. Every time I try to delete the folder, it still says I
need permission.

Is this is a clue? I tried your “uncheck read only box” tip first. But the
box wasn't checked nor unchecked. It was dark blue. By clicking it I can
toggle between checked, unchecked (light blue) and dark blue.

Any further suggestions welcome.

Blackbeard
Guest
Posts: n/a
 
Re: Cannot delete desktop folder
Posted: 03-09-2008, 03:28 PM
Many thanks for your suggestions, Jeff. I have carefully followed them all,
but none has worked. Every time I try to delete the folder, it still says I
need permission.

Is this is a clue? I tried your “uncheck read only box” tip first. But the
box wasn't checked nor unchecked. It was dark blue. By clicking it I can
toggle between checked, unchecked (light blue) and dark blue.

Any further suggestions welcome.

Blackbeard
Guest
Posts: n/a
 
Re: Cannot delete desktop folder
Posted: 03-09-2008, 03:42 PM
Oh! I have just succeeded in deleting the folder. Trouble is, I don't know
how I did it. I was just trying everything one after the other, and found a
box called "Special permissions" somewhere. I can't remember if I checked or
unchecked it, but it did the trick. Thank you for all your help anyway.
jihchiang
Guest
Posts: n/a
 
Re: Cannot delete desktop folder
Posted: 03-10-2008, 01:35 AM
You'll have to take "ownership" to the folder,
1.) right click on the folder. Choose Properties
2.) click Security then click Advance
3.) click Effevtive Permission then click Select
4.) enter your name ( as it appears on your account ) insie the box, then
click OK
5. you'll see a list all checkmarked. Scroll down to the last one that says
ownership. You are the owner of that folder. click OK and close all
those windows.
6.) you can now delete the folder as you wish.
Please post a report if you are successful or not. Good luck.
"Blackbeard" <Blackbeard@discussions.microsoft.com> wrote in message
news:53377032-034C-4813-94A6-B6585E84055A@microsoft.com...
>I have Vista on my laptop. I copied a folder on my (Windows XP) desktop
>onto
> a CD and from there onto my laptop desktop. I cannot now delete that
> folder,
> as I am told I need permission. How do I give myself permission, please?
Blackbeard
Guest
Posts: n/a
 
Re: Cannot delete desktop folder
Posted: 03-10-2008, 03:43 AM
Thank you
 
LinkBack Thread Tools Display Modes
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I delete multiples of Desktop file folder? Bellas Windows Vista File Management 8 11-21-2007 05:13 PM
Cannot delete folder on my Vista desktop - Access Denied Christian Dreiner Windows Vista File Management 5 03-11-2007 11:17 PM
Auto delete of messages in delete folder. Spectrumone Windows Vista Mail 2 02-15-2007 12:46 AM
Cannot Delete Some Messages In The Delete Folder MidnightRambler Windows Vista Mail 1 12-16-2006 09:36 PM
BROWSER OR DESKTOP LOCK UP WHEN ATTEMPTING TO DELETE A FILE, FOLDER, OR ICON DON Windows XP Basics 0 09-04-2003 05:07 PM