Device Installation - Elevated Privileges

Posted: 02-12-2008, 03:20 PM
Hi, I have a quesiton which has been bugging me since we rolled out Vista to
our desktops almost a years ago....

Whenever I have to go to a users PC to install a new device (USB Storage Key
for example) I usually have to spend about 10 minutes there as the Elevated
Privileges dialoge box will pop up several times, as each component of the
device tries to install itself...

Is there any way to set this up so that when you apporve a device for
installation, all the drivers and components for that device are also
approved for install - it's quite frustratring having to spend 10 minutes
doing a task which should take 30 seconds!

Thanks in advance for any help/advice

Mike Dower
Sys admin - Ministry of Sound

Device Installation - Elevated Privileges


Responses to "Device Installation - Elevated Privileges"

John
Guest
Posts: n/a
 
Re: Device Installation - Elevated Privileges
Posted: 02-12-2008, 06:52 PM
You might try turning off UAC while installing devices and then turn it back
on when done.

"Mike Dower" <MikeDower@discussions.microsoft.com> wrote in message
news:542CC4AA-770E-4B83-A7E3-0B05B906B287@microsoft.com...
> Hi, I have a quesiton which has been bugging me since we rolled out Vista
> to
> our desktops almost a years ago....
>
> Whenever I have to go to a users PC to install a new device (USB Storage
> Key
> for example) I usually have to spend about 10 minutes there as the
> Elevated
> Privileges dialoge box will pop up several times, as each component of the
> device tries to install itself...
>
> Is there any way to set this up so that when you apporve a device for
> installation, all the drivers and components for that device are also
> approved for install - it's quite frustratring having to spend 10 minutes
> doing a task which should take 30 seconds!
>
> Thanks in advance for any help/advice
>
> Mike Dower
> Sys admin - Ministry of Sound

Mike Dower
Guest
Posts: n/a
 
Re: Device Installation - Elevated Privileges
Posted: 02-13-2008, 08:49 AM
Hi John,

That's a good idea and somerthing I have tried before, but it requires a
restart so can actually end taking longer than just waiting and entering my
username and password for elevated privileges 4 times!

Thanks for the suggestion

Mike

"John" wrote:
> You might try turning off UAC while installing devices and then turn it back
> on when done.
>
> "Mike Dower" <MikeDower@discussions.microsoft.com> wrote in message
> news:542CC4AA-770E-4B83-A7E3-0B05B906B287@microsoft.com...
> > Hi, I have a quesiton which has been bugging me since we rolled out Vista
> > to
> > our desktops almost a years ago....
> >
> > Whenever I have to go to a users PC to install a new device (USB Storage
> > Key
> > for example) I usually have to spend about 10 minutes there as the
> > Elevated
> > Privileges dialoge box will pop up several times, as each component of the
> > device tries to install itself...
> >
> > Is there any way to set this up so that when you apporve a device for
> > installation, all the drivers and components for that device are also
> > approved for install - it's quite frustratring having to spend 10 minutes
> > doing a task which should take 30 seconds!
> >
> > Thanks in advance for any help/advice
> >
> > Mike Dower
> > Sys admin - Ministry of Sound
>
>
>
John
Guest
Posts: n/a
 
Re: Device Installation - Elevated Privileges
Posted: 02-16-2008, 08:22 PM
Just out of curiosity, did you turn off UAC via gpedit.msc or Control Panel?

"Mike Dower" <MikeDower@discussions.microsoft.com> wrote in message
news:9282FEE4-4BF7-4599-A143-479C9F44CD8B@microsoft.com...
> Hi John,
>
> That's a good idea and somerthing I have tried before, but it requires a
> restart so can actually end taking longer than just waiting and entering
> my
> username and password for elevated privileges 4 times!
>
> Thanks for the suggestion
>
> Mike
>
> "John" wrote:
>
>> You might try turning off UAC while installing devices and then turn it
>> back
>> on when done.
>>
>> "Mike Dower" <MikeDower@discussions.microsoft.com> wrote in message
>> news:542CC4AA-770E-4B83-A7E3-0B05B906B287@microsoft.com...
>> > Hi, I have a quesiton which has been bugging me since we rolled out
>> > Vista
>> > to
>> > our desktops almost a years ago....
>> >
>> > Whenever I have to go to a users PC to install a new device (USB
>> > Storage
>> > Key
>> > for example) I usually have to spend about 10 minutes there as the
>> > Elevated
>> > Privileges dialoge box will pop up several times, as each component of
>> > the
>> > device tries to install itself...
>> >
>> > Is there any way to set this up so that when you apporve a device for
>> > installation, all the drivers and components for that device are also
>> > approved for install - it's quite frustratring having to spend 10
>> > minutes
>> > doing a task which should take 30 seconds!
>> >
>> > Thanks in advance for any help/advice
>> >
>> > Mike Dower
>> > Sys admin - Ministry of Sound
>>
>>
>>

 
LinkBack Thread Tools Display Modes
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Device Installation - Elevated Privileges Mike Dower Windows Vista Administration 3 02-14-2008 12:43 AM
run a legacy CPL elevated message Mentos Windows Vista Security 2 11-12-2007 01:18 AM
Elevated privileges for MSI Package in Vista. Marimuthu Windows Vista Security 2 01-13-2007 02:07 PM
Installing printers with elevated privileges WILL Windows XP Printers / Scanners / Fax 0 02-07-2004 03:04 AM
XP installation fails at Device Installation AC Windows XP Setup 0 01-06-2004 01:13 AM