DHCP Service Fails to Start with "Access Denied" Error

Posted: 02-20-2008, 09:12 PM
This morning, my laptop stopped connecting to the internet. I could see it
get hung up while getting an IP address.

After poking around, I discovered that the DHCP service repeatedly failed to
start. Specifically, it failed with an error 5 "Access Denied" message, and
continues to do so when I attempt to start it manually. So far I have
1. Ensured that all services on which DHCP is dependent are running (they are)
2. Played with the account to use for the DHCP service
3. Followed the directions in KB article 943996 which prescribes editing
permissions on registry keys.
4. Compared the dhcp security descriptor to that of the following post
http://windowshelp.microsoft.com/com...=en-us&m=1&p=1
and observed that they were the same, except for an extra SACL. I did not
attempt to change the security descriptor, as I assumed it was just giving
extra permissions.

None of these things have had any effect, except that changing the user
account generated another error until I changed it back.

My computer is a Thinkpad X61 running Vista Business. I know of no new
software, updates, or anything that should have caused this issue.

Can anyone help with this problem? I can't generally use a static IP address.

Thanks!

DHCP Service Fails to Start with "Access Denied" Error


Responses to "DHCP Service Fails to Start with "Access Denied" Error"

jamesvdm
Guest
Posts: n/a
 
RE: DHCP Service Fails to Start with "Access Denied" Error
Posted: 02-21-2008, 07:02 AM
Lenovo machines ship with a heap of software that messes with network
settings, therefore I would run Thinkpad Software Update and apply all
updates from Lenovo.

I hope this helps you out.

James

"cwilkens" wrote:
> This morning, my laptop stopped connecting to the internet. I could see it
> get hung up while getting an IP address.
>
> After poking around, I discovered that the DHCP service repeatedly failed to
> start. Specifically, it failed with an error 5 "Access Denied" message, and
> continues to do so when I attempt to start it manually. So far I have
> 1. Ensured that all services on which DHCP is dependent are running (they are)
> 2. Played with the account to use for the DHCP service
> 3. Followed the directions in KB article 943996 which prescribes editing
> permissions on registry keys.
> 4. Compared the dhcp security descriptor to that of the following post
> http://windowshelp.microsoft.com/com...=en-us&m=1&p=1
> and observed that they were the same, except for an extra SACL. I did not
> attempt to change the security descriptor, as I assumed it was just giving
> extra permissions.
>
> None of these things have had any effect, except that changing the user
> account generated another error until I changed it back.
>
> My computer is a Thinkpad X61 running Vista Business. I know of no new
> software, updates, or anything that should have caused this issue.
>
> Can anyone help with this problem? I can't generally use a static IP address.
>
> Thanks!
cwilkens
Guest
Posts: n/a
 
RE: DHCP Service Fails to Start with "Access Denied" Error
Posted: 02-22-2008, 06:30 PM
Thanks for the suggestion. I tried installing all Lenovo updates, but it
didn't help.

Ultimately, a "System Restore" to a time prior to the issue fixed it.

"jamesvdm" wrote:
> Lenovo machines ship with a heap of software that messes with network
> settings, therefore I would run Thinkpad Software Update and apply all
> updates from Lenovo.
>
> I hope this helps you out.
>
> James
>
> "cwilkens" wrote:
>
> > This morning, my laptop stopped connecting to the internet. I could see it
> > get hung up while getting an IP address.
> >
> > After poking around, I discovered that the DHCP service repeatedly failed to
> > start. Specifically, it failed with an error 5 "Access Denied" message, and
> > continues to do so when I attempt to start it manually. So far I have
> > 1. Ensured that all services on which DHCP is dependent are running (they are)
> > 2. Played with the account to use for the DHCP service
> > 3. Followed the directions in KB article 943996 which prescribes editing
> > permissions on registry keys.
> > 4. Compared the dhcp security descriptor to that of the following post
> > http://windowshelp.microsoft.com/com...=en-us&m=1&p=1
> > and observed that they were the same, except for an extra SACL. I did not
> > attempt to change the security descriptor, as I assumed it was just giving
> > extra permissions.
> >
> > None of these things have had any effect, except that changing the user
> > account generated another error until I changed it back.
> >
> > My computer is a Thinkpad X61 running Vista Business. I know of no new
> > software, updates, or anything that should have caused this issue.
> >
> > Can anyone help with this problem? I can't generally use a static IP address.
> >
> > Thanks!
 
LinkBack Thread Tools Display Modes
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Service startup fails with "Access Denied" after Win2K3 domain joi srshowers Windows Vista Networking & Sharing 11 09-06-2007 02:52 PM
Service Startup fails with "Access denied" Aule Windows Vista 2 09-08-2006 08:18 PM
SP1 Installation Fails with "Access Denied" Jay Greenberg Windows XP Setup 1 09-29-2003 05:44 PM
service control manager "access is denied" Mad Max Windows XP New Users 1 08-21-2003 02:41 AM
Installing USB hub fails - "access denied" - mondll.dll? lynn Windows XP Hardware 2 08-04-2003 10:38 AM