Offline Files gives "Access is Denied" error

Posted: 03-28-2007, 12:56 AM
I recently upgraded from XP Pro SP2 to Vista Ultimate on my notebook. I use
the "Always Available Offline" option to keep a copy of my crucial files
available when I am travelling with my notebook. If I update a file while not
connected to my network, it will not sync when I reconnect, but instead comes
up with an "Access is Denied" error. I've checked the security settings to
ensure that the Everyone group has full control of the directory, but still
nothing. I also tried disabling and re-enabling the "Always Available
Offline" option, but it still has the same problem. There doesn't seem to be
any problems with accessing the files normally, only the Sync Manager seems
to have the problem. If I manually delete the file on my desktop computer it
will then sync, but this seems like a lot of hassle.


Eric Sambell

Offline Files gives "Access is Denied" error


Responses to "Offline Files gives "Access is Denied" error"

rmwestbrook
Guest
Posts: n/a
 
RE: Offline Files gives "Access is Denied" error
Posted: 04-05-2007, 07:06 PM
Have you noticed any files that look like {12349299293020...}.tmp on your
file share? I had experenced a very similar problem, I have not found a
complete fix yet, but figured out that if you rename the file with the error
it will sync and then you can rename it back. Might be a little better than
deleting them.

"Eric Sambell" wrote:
> I recently upgraded from XP Pro SP2 to Vista Ultimate on my notebook. I use
> the "Always Available Offline" option to keep a copy of my crucial files
> available when I am travelling with my notebook. If I update a file while not
> connected to my network, it will not sync when I reconnect, but instead comes
> up with an "Access is Denied" error. I've checked the security settings to
> ensure that the Everyone group has full control of the directory, but still
> nothing. I also tried disabling and re-enabling the "Always Available
> Offline" option, but it still has the same problem. There doesn't seem to be
> any problems with accessing the files normally, only the Sync Manager seems
> to have the problem. If I manually delete the file on my desktop computer it
> will then sync, but this seems like a lot of hassle.
>
>
> Eric Sambell
Eric Sambell
Guest
Posts: n/a
 
RE: Offline Files gives "Access is Denied" error
Posted: 04-05-2007, 07:42 PM
I am swimming in those files, not sure what they were. I was able to get rid
of the problem by double checking that the everyone group had full control in
both the "Sharing" and "Security" tab for the folder. It turns out that I had
all the permissions set corectly on the "Security" tab, but not on the
"Sharing" tab. Don't know if it is the same problem you were having, but
maybe that will help. I'm also considering deleting all those .tmp files, but
I haven't decided yet.

Eric

"rmwestbrook" wrote:
> Have you noticed any files that look like {12349299293020...}.tmp on your
> file share? I had experenced a very similar problem, I have not found a
> complete fix yet, but figured out that if you rename the file with the error
> it will sync and then you can rename it back. Might be a little better than
> deleting them.
>
> "Eric Sambell" wrote:
>
> > I recently upgraded from XP Pro SP2 to Vista Ultimate on my notebook. I use
> > the "Always Available Offline" option to keep a copy of my crucial files
> > available when I am travelling with my notebook. If I update a file while not
> > connected to my network, it will not sync when I reconnect, but instead comes
> > up with an "Access is Denied" error. I've checked the security settings to
> > ensure that the Everyone group has full control of the directory, but still
> > nothing. I also tried disabling and re-enabling the "Always Available
> > Offline" option, but it still has the same problem. There doesn't seem to be
> > any problems with accessing the files normally, only the Sync Manager seems
> > to have the problem. If I manually delete the file on my desktop computer it
> > will then sync, but this seems like a lot of hassle.
> >
> >
> > Eric Sambell
Shubhankar Sanyal [MSFT]
Guest
Posts: n/a
 
Re: Offline Files gives "Access is Denied" error
Posted: 04-06-2007, 07:07 PM
rmwestbrook- The tmp file problem does seem to be the bug that Eric
describes. A very simple workaround is to set sharing permissions to "Full
control" for everyone who is expected to modify the files.
Eric- If you have been able to succesfully sync your offline changes after
changing the share permissions to "Full Control", then it is fine to delete
the tmp files.

Thanks,
Shubhankar

"Eric Sambell" <EricSambell@discussions.microsoft.com> wrote in message
news:B072BA90-DC0C-42CE-8A58-56882CE66C89@microsoft.com...
>I am swimming in those files, not sure what they were. I was able to get
>rid
> of the problem by double checking that the everyone group had full control
> in
> both the "Sharing" and "Security" tab for the folder. It turns out that I
> had
> all the permissions set corectly on the "Security" tab, but not on the
> "Sharing" tab. Don't know if it is the same problem you were having, but
> maybe that will help. I'm also considering deleting all those .tmp files,
> but
> I haven't decided yet.
>
> Eric
>
> "rmwestbrook" wrote:
>
>> Have you noticed any files that look like {12349299293020...}.tmp on your
>> file share? I had experenced a very similar problem, I have not found a
>> complete fix yet, but figured out that if you rename the file with the
>> error
>> it will sync and then you can rename it back. Might be a little better
>> than
>> deleting them.
>>
>> "Eric Sambell" wrote:
>>
>> > I recently upgraded from XP Pro SP2 to Vista Ultimate on my notebook. I
>> > use
>> > the "Always Available Offline" option to keep a copy of my crucial
>> > files
>> > available when I am travelling with my notebook. If I update a file
>> > while not
>> > connected to my network, it will not sync when I reconnect, but instead
>> > comes
>> > up with an "Access is Denied" error. I've checked the security settings
>> > to
>> > ensure that the Everyone group has full control of the directory, but
>> > still
>> > nothing. I also tried disabling and re-enabling the "Always Available
>> > Offline" option, but it still has the same problem. There doesn't seem
>> > to be
>> > any problems with accessing the files normally, only the Sync Manager
>> > seems
>> > to have the problem. If I manually delete the file on my desktop
>> > computer it
>> > will then sync, but this seems like a lot of hassle.
>> >
>> >
>> > Eric Sambell
rmwestbrook
Guest
Posts: n/a
 
Re: Offline Files gives "Access is Denied" error
Posted: 04-09-2007, 03:34 PM
Shubhankar,

Thanks for the response! Do users need to have "Full Control" of the share
and the files? The share I am using has change permissions for everyone, but
not full control. But, the files and folder have "Full Control" for the user
who is having this problem.

Thanks,
Ryan

"Shubhankar Sanyal [MSFT]" wrote:
> rmwestbrook- The tmp file problem does seem to be the bug that Eric
> describes. A very simple workaround is to set sharing permissions to "Full
> control" for everyone who is expected to modify the files.
> Eric- If you have been able to succesfully sync your offline changes after
> changing the share permissions to "Full Control", then it is fine to delete
> the tmp files.
>
> Thanks,
> Shubhankar
>
> "Eric Sambell" <EricSambell@discussions.microsoft.com> wrote in message
> news:B072BA90-DC0C-42CE-8A58-56882CE66C89@microsoft.com...
> >I am swimming in those files, not sure what they were. I was able to get
> >rid
> > of the problem by double checking that the everyone group had full control
> > in
> > both the "Sharing" and "Security" tab for the folder. It turns out that I
> > had
> > all the permissions set corectly on the "Security" tab, but not on the
> > "Sharing" tab. Don't know if it is the same problem you were having, but
> > maybe that will help. I'm also considering deleting all those .tmp files,
> > but
> > I haven't decided yet.
> >
> > Eric
> >
> > "rmwestbrook" wrote:
> >
> >> Have you noticed any files that look like {12349299293020...}.tmp on your
> >> file share? I had experenced a very similar problem, I have not found a
> >> complete fix yet, but figured out that if you rename the file with the
> >> error
> >> it will sync and then you can rename it back. Might be a little better
> >> than
> >> deleting them.
> >>
> >> "Eric Sambell" wrote:
> >>
> >> > I recently upgraded from XP Pro SP2 to Vista Ultimate on my notebook. I
> >> > use
> >> > the "Always Available Offline" option to keep a copy of my crucial
> >> > files
> >> > available when I am travelling with my notebook. If I update a file
> >> > while not
> >> > connected to my network, it will not sync when I reconnect, but instead
> >> > comes
> >> > up with an "Access is Denied" error. I've checked the security settings
> >> > to
> >> > ensure that the Everyone group has full control of the directory, but
> >> > still
> >> > nothing. I also tried disabling and re-enabling the "Always Available
> >> > Offline" option, but it still has the same problem. There doesn't seem
> >> > to be
> >> > any problems with accessing the files normally, only the Sync Manager
> >> > seems
> >> > to have the problem. If I manually delete the file on my desktop
> >> > computer it
> >> > will then sync, but this seems like a lot of hassle.
> >> >
> >> >
> >> > Eric Sambell
>
>
rmwestbrook
Guest
Posts: n/a
 
Re: Offline Files gives "Access is Denied" error
Posted: 04-09-2007, 04:32 PM
Shubhankar,

I just changed the share permissions to "Full Control" and the problem
cleared! Thanks for the help.

Ryan

"rmwestbrook" wrote:
> Shubhankar,
>
> Thanks for the response! Do users need to have "Full Control" of the share
> and the files? The share I am using has change permissions for everyone, but
> not full control. But, the files and folder have "Full Control" for the user
> who is having this problem.
>
> Thanks,
> Ryan
>
> "Shubhankar Sanyal [MSFT]" wrote:
>
> > rmwestbrook- The tmp file problem does seem to be the bug that Eric
> > describes. A very simple workaround is to set sharing permissions to "Full
> > control" for everyone who is expected to modify the files.
> > Eric- If you have been able to succesfully sync your offline changes after
> > changing the share permissions to "Full Control", then it is fine to delete
> > the tmp files.
> >
> > Thanks,
> > Shubhankar
> >
> > "Eric Sambell" <EricSambell@discussions.microsoft.com> wrote in message
> > news:B072BA90-DC0C-42CE-8A58-56882CE66C89@microsoft.com...
> > >I am swimming in those files, not sure what they were. I was able to get
> > >rid
> > > of the problem by double checking that the everyone group had full control
> > > in
> > > both the "Sharing" and "Security" tab for the folder. It turns out that I
> > > had
> > > all the permissions set corectly on the "Security" tab, but not on the
> > > "Sharing" tab. Don't know if it is the same problem you were having, but
> > > maybe that will help. I'm also considering deleting all those .tmp files,
> > > but
> > > I haven't decided yet.
> > >
> > > Eric
> > >
> > > "rmwestbrook" wrote:
> > >
> > >> Have you noticed any files that look like {12349299293020...}.tmp on your
> > >> file share? I had experenced a very similar problem, I have not found a
> > >> complete fix yet, but figured out that if you rename the file with the
> > >> error
> > >> it will sync and then you can rename it back. Might be a little better
> > >> than
> > >> deleting them.
> > >>
> > >> "Eric Sambell" wrote:
> > >>
> > >> > I recently upgraded from XP Pro SP2 to Vista Ultimate on my notebook. I
> > >> > use
> > >> > the "Always Available Offline" option to keep a copy of my crucial
> > >> > files
> > >> > available when I am travelling with my notebook. If I update a file
> > >> > while not
> > >> > connected to my network, it will not sync when I reconnect, but instead
> > >> > comes
> > >> > up with an "Access is Denied" error. I've checked the security settings
> > >> > to
> > >> > ensure that the Everyone group has full control of the directory, but
> > >> > still
> > >> > nothing. I also tried disabling and re-enabling the "Always Available
> > >> > Offline" option, but it still has the same problem. There doesn't seem
> > >> > to be
> > >> > any problems with accessing the files normally, only the Sync Manager
> > >> > seems
> > >> > to have the problem. If I manually delete the file on my desktop
> > >> > computer it
> > >> > will then sync, but this seems like a lot of hassle.
> > >> >
> > >> >
> > >> > Eric Sambell
> >
> >
Mantvydas
Guest
Posts: n/a
 
Re: Offline Files gives "Access is Denied" error
Posted: 06-18-2007, 09:13 PM
Hello,

I also have the very same problem, only that my situation is a little
different.

I have a DFS folder share.

\\domain.com\files\personal

And my group policy is set to redirect my documents to
\\domain.com\files\personal\

So actually my My Documents folder is now in
\\domain.com\files\personal\username\mydocuments

And the permissions have been automatically granted to me and to SYSTEM
only.

And Offline files is telling Access Denied to several folders only
\\domain.com\files\personal\username\mydocuments\i nfolder1\folder1 and
\\domain.com\files\personal\username\mydocuments\i nfolder2\infolder\folder2
files

How about that complexity, Mr. Shubhankar?

Do you know, maybe there's a fix already, no more a workaround from
Microsoft?


Mantvydas


"rmwestbrook" <rmwestbrook@discussions.microsoft.com> wrote in message
news:96D2C24E-AE1D-4BFC-B133-F64DBA4178C8@microsoft.com...
> Shubhankar,
>
> I just changed the share permissions to "Full Control" and the problem
> cleared! Thanks for the help.
>
> Ryan
>
>> "Shubhankar Sanyal [MSFT]" wrote:
>>
>> > rmwestbrook- The tmp file problem does seem to be the bug that Eric
>> > describes. A very simple workaround is to set sharing permissions to
>> > "Full
>> > control" for everyone who is expected to modify the files.
>> > Eric- If you have been able to succesfully sync your offline changes
>> > after
>> > changing the share permissions to "Full Control", then it is fine to
>> > delete
>> > the tmp files.
>> >
>> > Thanks,
>> > Shubhankar
Shubhankar Sanyal [MSFT]
Guest
Posts: n/a
 
Re: Offline Files gives "Access is Denied" error
Posted: 07-17-2007, 06:37 PM
Sorry I managed to completely miss this mail. In case you are still having
the problem-
Are you able to access the folders and all files that offline files gives an
error for, through explorer?

Thanks,
Shubhankar

"Mantvydas" <mantvydas at gmail dot com> wrote in message
news:23FA8D23-B95C-46FA-BEB0-E7DECE1EA425@microsoft.com...
> Hello,
>
> I also have the very same problem, only that my situation is a little
> different.
>
> I have a DFS folder share.
>
> \\domain.com\files\personal
>
> And my group policy is set to redirect my documents to
> \\domain.com\files\personal\
>
> So actually my My Documents folder is now in
> \\domain.com\files\personal\username\mydocuments
>
> And the permissions have been automatically granted to me and to SYSTEM
> only.
>
> And Offline files is telling Access Denied to several folders only
> \\domain.com\files\personal\username\mydocuments\i nfolder1\folder1 and
> \\domain.com\files\personal\username\mydocuments\i nfolder2\infolder\folder2
> files
>
> How about that complexity, Mr. Shubhankar?
>
> Do you know, maybe there's a fix already, no more a workaround from
> Microsoft?
>
>
> Mantvydas
>
>
> "rmwestbrook" <rmwestbrook@discussions.microsoft.com> wrote in message
> news:96D2C24E-AE1D-4BFC-B133-F64DBA4178C8@microsoft.com...
>> Shubhankar,
>>
>> I just changed the share permissions to "Full Control" and the problem
>> cleared! Thanks for the help.
>>
>> Ryan
>>
>>> "Shubhankar Sanyal [MSFT]" wrote:
>>>
>>> > rmwestbrook- The tmp file problem does seem to be the bug that Eric
>>> > describes. A very simple workaround is to set sharing permissions to
>>> > "Full
>>> > control" for everyone who is expected to modify the files.
>>> > Eric- If you have been able to succesfully sync your offline changes
>>> > after
>>> > changing the share permissions to "Full Control", then it is fine to
>>> > delete
>>> > the tmp files.
>>> >
>>> > Thanks,
>>> > Shubhankar
>
Mantvydas
Guest
Posts: n/a
 
Re: Offline Files gives "Access is Denied" error
Posted: 09-03-2007, 05:35 PM
Oh... I managed to completely forfeit waiting for the answer to my e-mail.

Yes. I'm still having this same problem.

Yes. I am able to access the folders and all files that offline files gives
an error for.

For example, it complains that Access is denied. to a ZIP file. But I can
easily doubleclick on it, and see the contents of it.

However, beside that file there's numerous {GUID}.tmp files in the folder,
each of which is the size of the zip.

Regards,
Mantvydas

"Shubhankar Sanyal [MSFT]" <sanyals@online.microsoft.com> wrote in message
news:OvgiPGKyHHA.3564@TK2MSFTNGP06.phx.gbl...
> Sorry I managed to completely miss this mail. In case you are still having
> the problem-
> Are you able to access the folders and all files that offline files gives
> an error for, through explorer?
>
> Thanks,
> Shubhankar
>
> "Mantvydas" <mantvydas at gmail dot com> wrote in message
> news:23FA8D23-B95C-46FA-BEB0-E7DECE1EA425@microsoft.com...
>> Hello,
>>
>> I also have the very same problem, only that my situation is a little
>> different.
>>
>> I have a DFS folder share.
>>
>> \\domain.com\files\personal
>>
>> And my group policy is set to redirect my documents to
>> \\domain.com\files\personal\
>>
>> So actually my My Documents folder is now in
>> \\domain.com\files\personal\username\mydocuments
>>
>> And the permissions have been automatically granted to me and to SYSTEM
>> only.
>>
>> And Offline files is telling Access Denied to several folders only
>> \\domain.com\files\personal\username\mydocuments\i nfolder1\folder1 and
>> \\domain.com\files\personal\username\mydocuments\i nfolder2\infolder\folder2
>> files
>>
>> How about that complexity, Mr. Shubhankar?
>>
>> Do you know, maybe there's a fix already, no more a workaround from
>> Microsoft?
>>
>>
>> Mantvydas
>>
>>
>> "rmwestbrook" <rmwestbrook@discussions.microsoft.com> wrote in message
>> news:96D2C24E-AE1D-4BFC-B133-F64DBA4178C8@microsoft.com...
>>> Shubhankar,
>>>
>>> I just changed the share permissions to "Full Control" and the problem
>>> cleared! Thanks for the help.
>>>
>>> Ryan
>>>
>>>> "Shubhankar Sanyal [MSFT]" wrote:
>>>>
>>>> > rmwestbrook- The tmp file problem does seem to be the bug that Eric
>>>> > describes. A very simple workaround is to set sharing permissions to
>>>> > "Full
>>>> > control" for everyone who is expected to modify the files.
>>>> > Eric- If you have been able to succesfully sync your offline changes
>>>> > after
>>>> > changing the share permissions to "Full Control", then it is fine to
>>>> > delete
>>>> > the tmp files.
>>>> >
>>>> > Thanks,
>>>> > Shubhankar
>>
>
Bill Wood
Guest
Posts: n/a
 
Re: Offline Files gives "Access is Denied" error
Posted: 11-17-2007, 01:40 AM
The answer has been found! See this post:

Subject: Offline Files - tmp files - GUID - Access is denied - Sync
Posted on November 16, 2007...

There finally is an answer. After looking EVERYWHERE, I found the Microsoft
solution... Check the third reply I made. It has a link to the MS KB
article for the fix.

I have applied the PRE-SP1 patch and it worked on my computer! FINALLY!!!
I HAVE to have the offline files working or it creates major problems for my
work!

"Mantvydas" wrote:
> Dear Shubhankar,
>
> I'm really interested in solving my problem. I know a time consuming
> workaround for it (move the numerous "Access denied" files from their
> network locations to C:\ drive, delete all their {GUID}.TMP files on the
> network, sync the offline files with empty network folders, and get the
> files back to the network places where they were), but I really want to
> contribute to the permanent fix, so it's most probably included in SP1,
> rather than leaving this behind.
>
> As I've said before, setting Permissions to Full Control is not an option
> for me. It's My Documents.
>
> What more information would you require?
>
> Besides, I believe that this situation is to blame why Windows is taking
> over an hour to log me on (time from entering my password, to seeing my
> desktop). All I see, is Welcome... during the whole hour.
>
> Mantvydas
>
> "Mantvydas" <mantvydas at gmail dot com> wrote in message
> news:1CBD91B0-D699-42CA-9897-F455223E0BF5@microsoft.com...
> > Oh... I managed to completely forfeit waiting for the answer to my e-mail.
> >
> > Yes. I'm still having this same problem.
> >
> > Yes. I am able to access the folders and all files that offline files
> > gives an error for.
> >
> > For example, it complains that Access is denied. to a ZIP file. But I can
> > easily doubleclick on it, and see the contents of it.
> >
> > However, beside that file there's numerous {GUID}.tmp files in the folder,
> > each of which is the size of the zip.
> >
> > Regards,
> > Mantvydas
> >
> > "Shubhankar Sanyal [MSFT]" <sanyals@online.microsoft.com> wrote in message
> > news:OvgiPGKyHHA.3564@TK2MSFTNGP06.phx.gbl...
> >> Sorry I managed to completely miss this mail. In case you are still
> >> having the problem-
> >> Are you able to access the folders and all files that offline files gives
> >> an error for, through explorer?
> >>
> >> Thanks,
> >> Shubhankar
> >>
> >> "Mantvydas" <mantvydas at gmail dot com> wrote in message
> >> news:23FA8D23-B95C-46FA-BEB0-E7DECE1EA425@microsoft.com...
> >>> Hello,
> >>>
> >>> I also have the very same problem, only that my situation is a little
> >>> different.
> >>>
> >>> I have a DFS folder share.
> >>>
> >>> \\domain.com\files\personal
> >>>
> >>> And my group policy is set to redirect my documents to
> >>> \\domain.com\files\personal\
> >>>
> >>> So actually my My Documents folder is now in
> >>> \\domain.com\files\personal\username\mydocuments
> >>>
> >>> And the permissions have been automatically granted to me and to SYSTEM
> >>> only.
> >>>
> >>> And Offline files is telling Access Denied to several folders only
> >>> \\domain.com\files\personal\username\mydocuments\i nfolder1\folder1 and
> >>> \\domain.com\files\personal\username\mydocuments\i nfolder2\infolder\folder2
> >>> files
> >>>
> >>> How about that complexity, Mr. Shubhankar?
> >>>
> >>> Do you know, maybe there's a fix already, no more a workaround from
> >>> Microsoft?
> >>>
> >>>
> >>> Mantvydas
> >>>
> >>>
> >>> "rmwestbrook" <rmwestbrook@discussions.microsoft.com> wrote in message
> >>> news:96D2C24E-AE1D-4BFC-B133-F64DBA4178C8@microsoft.com...
> >>>> Shubhankar,
> >>>>
> >>>> I just changed the share permissions to "Full Control" and the problem
> >>>> cleared! Thanks for the help.
> >>>>
> >>>> Ryan
> >>>>
> >>>>> "Shubhankar Sanyal [MSFT]" wrote:
> >>>>>
> >>>>> > rmwestbrook- The tmp file problem does seem to be the bug that Eric
> >>>>> > describes. A very simple workaround is to set sharing permissions to
> >>>>> > "Full
> >>>>> > control" for everyone who is expected to modify the files.
> >>>>> > Eric- If you have been able to succesfully sync your offline changes
> >>>>> > after
> >>>>> > changing the share permissions to "Full Control", then it is fine to
> >>>>> > delete
> >>>>> > the tmp files.
> >>>>> >
> >>>>> > Thanks,
> >>>>> > Shubhankar
> >>>
> >>
> >
>
 
LinkBack Thread Tools Display Modes
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with offline files: Synchronization error "no access" Martin Rhinow Windows Vista File Management 0 04-30-2007 07:59 AM
Offline files "Access Denied" when synching to Mapped Drive Migration help Windows XP Configuration & Management 0 12-15-2004 08:07 PM
Cisco VPN Installation "Plug and Play" access denied Error Joel Davis Windows XP Help & Support 1 10-16-2003 02:27 AM
"Access is Denied" Error Message François Windows XP Accessibility 3 08-07-2003 12:26 AM
Deleting "Access Denied" Files Joe Kennedy Windows XP Security & Administration 1 07-06-2003 05:25 PM