Registry Problem!

Posted: 01-22-2009, 09:45 AM

I wanted to test out Windows 7, so I made a backup of all my program
and 'documents' (http://www.vistax64.com/#). I used Automatic Backup
included with Vista. After backing up everything on 'my computer
(http://www.vistax64.com/#), I installed Windows 7 (upgraded) '32bit
(http://www.vistax64.com/#). When I decided it was time to go back t
Vista, I did a System Recovery ('hp' (http://www.vistax64.com/#)). Upo
restoring all of my data, I came upon the following problem

All of my program files are still intact, however I failed to make
backup of my Registry before upgrading to Windows 7

Now, my problem is, I have all these programs "installed" but no way t
access them, as they are not registered. For example, I just installe
Firefox to see if it would work (even though Firefox still shows file
in C:\WINDOWS\Program Files\Mozilla Firefox), and all the plugins fro
my previous Firefox installation are still there, but are no
registered, so when I open Firefox, I get this message

"Firefox could not install this item because of a failure in Chrom
Registration. Please contact the author about this problem.

I get this dialogue about 6 or 7 times before Firefox will start, an
when it starts, it tells me to restart Firefox.

Question of the Day:
Does the Automatic Backup in Vista perform some sort of backup of m
registry

Any help would be greatly appreciated

--
anthocology

Registry Problem!


Responses to "Registry Problem!"

Rick Rogers
Guest
Posts: n/a
 
Re: Registry Problem!
Posted: 01-22-2009, 11:13 AM
Hi,

The Vista backup program is for data unless you used the "complete" system
backup available in Business or Ultimate. Backing up program folders is
useless without the original system folders. It's more than just the
registry, there are also files placed in the system folders that are
necessary to support the software. You will need to reinstall the software
that you want.

--
Best of Luck,

Rick Rogers, aka "Nutcase" - Microsoft MVP
http://mvp.support.microsoft.com/
Windows help - www.rickrogers.org
My thoughts http://rick-mvp.blogspot.com

"anthocology" <guest@unknown-email.com> wrote in message
news:8755b6be4abc2e1094e2a7652536c745@nntp-gateway.com...
>
> I wanted to test out Windows 7, so I made a backup of all my programs
> and 'documents' (http://www.vistax64.com/#). I used Automatic Backup,
> included with Vista. After backing up everything on 'my computer'
> (http://www.vistax64.com/#), I installed Windows 7 (upgraded) '32bit'
> (http://www.vistax64.com/#). When I decided it was time to go back to
> Vista, I did a System Recovery ('hp' (http://www.vistax64.com/#)). Upon
> restoring all of my data, I came upon the following problem:
>
> All of my program files are still intact, however I failed to make a
> backup of my Registry before upgrading to Windows 7!
>
> Now, my problem is, I have all these programs "installed" but no way to
> access them, as they are not registered. For example, I just installed
> Firefox to see if it would work (even though Firefox still shows files
> in C:\WINDOWS\Program Files\Mozilla Firefox), and all the plugins from
> my previous Firefox installation are still there, but are not
> registered, so when I open Firefox, I get this message:
>
> "Firefox could not install this item because of a failure in Chrome
> Registration. Please contact the author about this problem."
>
> I get this dialogue about 6 or 7 times before Firefox will start, and
> when it starts, it tells me to restart Firefox.
>
> Question of the Day:
> Does the Automatic Backup in Vista perform some sort of backup of my
> registry?
>
> Any help would be greatly appreciated!
>
>
> --
> anthocology
 
LinkBack Thread Tools Display Modes
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Registry Problem Jose P Windows XP Performance & Maintenance 10 05-22-2004 07:09 AM
Registry Problem?? RK Windows XP Help & Support 0 02-24-2004 02:14 PM
DVD REGISTRY PROBLEM Urban Rump Windows XP Hardware 0 08-30-2003 11:56 AM
registry problem T.C. Windows XP 0 07-17-2003 10:15 PM
Registry Problem jp Windows XP Setup 0 07-02-2003 08:34 PM