Set the "No Sounds" scheme for the default user profile

Posted: 01-23-2009, 11:33 AM

Hi,

I'm working at a customer, who wants to have the No Sounds as Vista's
default Sound Scheme, in their image.

On XP it is easy. Open the Hive (registry) for the default user, and add the
following:
[HKEY_CURRENT_USER\AppEvents\Schemes]
"@"=".None"

In Vista however, it doesn't work.
The closest I get to set No Sounds as the Default Sound Scheme is by adding
the following to the default user hive (registry). I have verified the keys,
by running them after user logon. This changes the the sound scheme to "no
Sounds":
[HKEY_CURRENT_USER\AppEvents\Schemes]
"@"=".None"
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ .Default\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ CCSelect\.current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ Close\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ CriticalBatteryAlarm\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ DeviceConnect\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ DeviceDisconnect\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ DeviceFail\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ LowBatteryAlarm\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ MailBeep\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ Maximize\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ MenuCommand\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ MenuPopup\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ Minimize\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ Open\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ PrintComplete\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ RestoreDown\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ RestoreUp\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ ShowBand\.current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ SystemAsterisk\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ SystemExclamation\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ SystemExit\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ SystemHand\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ SystemNotification\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ SystemQuestion\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ SystemStart\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ WindowsLogoff\.Current]
"@"=""
[HKEY_CURRENT_USER\AppEvents\Schemes\Apps\.Default\ WindowsLogon\.Current]

This will not get me the No Sounds Profile, but part of it. Approximately
half of the actions still use the sound Scheme from Default Sound Scheme.
E.g. the Logon and the logoff action.

I suspect the "Vista Theme" is what is causing the behavior. If i select the
"no Sounds" Scheme and afterwards change Vista Theme (doesn't matter to which
one), the Sound Scheme returns to Default Sound (modified).

How do I get the default user profile to use the "No Sounds" Scheme as the
default?



Best Regards Thor

Set the "No Sounds" scheme for the default user profile


Responses to "Set the "No Sounds" scheme for the default user profile"

 
LinkBack Thread Tools Display Modes
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vista Home Premium - Single User Profile - "user profile cannot be loaded" tch8102 Windows Vista Administration 15 08-06-2008 11:56 PM
Vista Upgrade fails at "Gathering Files" when two users share the same user profile (ProfileImagePath). Message: "the upgrade was cancelled". Carl Farrington Windows Vista Install & Setup 4 10-24-2007 07:26 AM
"Default User" profile Adam Leinss Windows Vista Administration 5 02-28-2007 06:56 PM
"Files stored on this computer" and Customizing Default User profile Ed Customize Windows XP 3 09-26-2004 07:57 AM
Problems to see "Default Web Site" with a user who's not "Local administrtator"... JM Robi Windows XP Security & Administration 2 02-10-2004 07:26 AM