Vista Ultimate 32bit sec pool not working

Posted: 01-23-2008, 10:50 AM
Hi all,

I've Vista Ultimate 32 bit edition and I need to enable plain password
to connect to unix samba shares.
In XP/2000/20003 I could do this by going into secpol (local security
policy), well in vista it gives me the error:

Could not load snap-in

I've tried to register the dlls as indicated by the tech site of
microsoft but my problem still remains.

I've tried to log as administrator, tried to remove UAC and it keeps
telling the same Could not load the snap-in.

Can anyone help me out?

Thanks

Vista Ultimate 32bit sec pool not working


Responses to "Vista Ultimate 32bit sec pool not working"

Jesper
Guest
Posts: n/a
 
RE: Vista Ultimate 32bit sec pool not working
Posted: 01-23-2008, 05:28 PM
First, what version of Samba are you using that requires plaintext passwords?
The latest releases do not even support plaintext auth by default.

That, however, does not address the problem that you can't launch the secpol
snap-in. Can you add it to an MMC console? Try this:
1. Launch MMC.EXE from an elevated command prompt
2. Go to File\Add/Remove Snap-in...
3. Select "Group Policy Object Editor" and click Add>
4. Select "Local Computer" as the object and hit OK twice
5. Expand Computer Configuration\Windows Settings\Security Settings\Local
Policies
6. Click "Security Options"

Do you get an error of some kind there?

The typical cause of the error message you are seeing is either
administrative restrictions on which snap-ins you can load, or corruption of
the binaries on disk. The main binary for the snap-in is wsecedit.dll. Have
you done anything to modify that?


---
Your question may already be answered in Windows Vista Security:
http://www.amazon.com/gp/product/047...otectyourwi-20


"EtherealSoul" wrote:
> Hi all,
>
> I've Vista Ultimate 32 bit edition and I need to enable plain password
> to connect to unix samba shares.
> In XP/2000/20003 I could do this by going into secpol (local security
> policy), well in vista it gives me the error:
>
> Could not load snap-in
>
> I've tried to register the dlls as indicated by the tech site of
> microsoft but my problem still remains.
>
> I've tried to log as administrator, tried to remove UAC and it keeps
> telling the same Could not load the snap-in.
>
> Can anyone help me out?
>
> Thanks
>
EtherealSoul
Guest
Posts: n/a
 
Re: Vista Ultimate 32bit sec pool not working
Posted: 01-24-2008, 12:01 PM
Hi,

I've tried that and it didn't workout. Adding Group Policy Object
Editor it gives the same error. MMC could not load the snap-in.
I haven't installed any kind of software that could harm this file, at
least that I am aware of.

The version of samba is 3.0.14a for solaris.
Meanwhile, I've installed a virtual machine with XP and done the plain
password and it's working well.
But ... in vista it keeps the error :S

All other snap-in are working well.

Well ... I'll wait to see if the SP1 solves my problem otherwise I'll
have to reinstall this ...

Regards

On Jan 23, 5:28 pm, Jesper <Jes...@discussions.microsoft.com> wrote:
> First, what version of Samba are you using that requires plaintext passwords?
> The latest releases do not even support plaintext auth by default.
>
> That, however, does not address the problem that you can't launch the secpol
> snap-in. Can you add it to an MMC console? Try this:
> 1. Launch MMC.EXE from an elevated command prompt
> 2. Go to File\Add/Remove Snap-in...
> 3. Select "Group Policy Object Editor" and click Add>
> 4. Select "Local Computer" as the object and hit OK twice
> 5. Expand Computer Configuration\Windows Settings\Security Settings\Local
> Policies
> 6. Click "Security Options"
>
> Do you get an error of some kind there?
>
> The typical cause of the error message you are seeing is either
> administrative restrictions on which snap-ins you can load, or corruption of
> the binaries on disk. The main binary for the snap-in is wsecedit.dll. Have
> you done anything to modify that?
>
> ---
> Your question may already be answered in Windows Vista Security:http://www.amazon.com/gp/product/047...otectyourwi-20
>
> "EtherealSoul" wrote:
> > Hi all,
>
> > I've Vista Ultimate 32 bit edition and I need to enable plain password
> > to connect to unix samba shares.
> > In XP/2000/20003 I could do this by going into secpol (local security
> > policy), well in vista it gives me the error:
>
> > Could not load snap-in
>
> > I've tried to register the dlls as indicated by the tech site of
> > microsoft but my problem still remains.
>
> > I've tried to log as administrator, tried to remove UAC and it keeps
> > telling the same Could not load the snap-in.
>
> > Can anyone help me out?
>
> > Thanks
Jesper
Guest
Posts: n/a
 
Re: Vista Ultimate 32bit sec pool not working
Posted: 01-24-2008, 07:01 PM
In that case, either you have corruption of the files or are missing a file
required to load the snap-in. You can hope that SP1 will fix it, but that's a
long time to wait. You can also try to use Process Monitor to troubleshoot
any file open failures when it tries to load that snap-in. Process Monitor is
at: http://technet.microsoft.com/en-us/s.../bb896645.aspx.

As for Samba, I have not configured Samba for years, but I think you just
need to configure it properly to accept NTLM.
---
Your question may already be answered in Windows Vista Security:
http://www.amazon.com/gp/product/047...otectyourwi-20


"EtherealSoul" wrote:
> Hi,
>
> I've tried that and it didn't workout. Adding Group Policy Object
> Editor it gives the same error. MMC could not load the snap-in.
> I haven't installed any kind of software that could harm this file, at
> least that I am aware of.
>
> The version of samba is 3.0.14a for solaris.
> Meanwhile, I've installed a virtual machine with XP and done the plain
> password and it's working well.
> But ... in vista it keeps the error :S
>
> All other snap-in are working well.
>
> Well ... I'll wait to see if the SP1 solves my problem otherwise I'll
> have to reinstall this ...
>
> Regards
>
> On Jan 23, 5:28 pm, Jesper <Jes...@discussions.microsoft.com> wrote:
> > First, what version of Samba are you using that requires plaintext passwords?
> > The latest releases do not even support plaintext auth by default.
> >
> > That, however, does not address the problem that you can't launch the secpol
> > snap-in. Can you add it to an MMC console? Try this:
> > 1. Launch MMC.EXE from an elevated command prompt
> > 2. Go to File\Add/Remove Snap-in...
> > 3. Select "Group Policy Object Editor" and click Add>
> > 4. Select "Local Computer" as the object and hit OK twice
> > 5. Expand Computer Configuration\Windows Settings\Security Settings\Local
> > Policies
> > 6. Click "Security Options"
> >
> > Do you get an error of some kind there?
> >
> > The typical cause of the error message you are seeing is either
> > administrative restrictions on which snap-ins you can load, or corruption of
> > the binaries on disk. The main binary for the snap-in is wsecedit.dll. Have
> > you done anything to modify that?
> >
> > ---
> > Your question may already be answered in Windows Vista Security:http://www.amazon.com/gp/product/047...otectyourwi-20
> >
> > "EtherealSoul" wrote:
> > > Hi all,
> >
> > > I've Vista Ultimate 32 bit edition and I need to enable plain password
> > > to connect to unix samba shares.
> > > In XP/2000/20003 I could do this by going into secpol (local security
> > > policy), well in vista it gives me the error:
> >
> > > Could not load snap-in
> >
> > > I've tried to register the dlls as indicated by the tech site of
> > > microsoft but my problem still remains.
> >
> > > I've tried to log as administrator, tried to remove UAC and it keeps
> > > telling the same Could not load the snap-in.
> >
> > > Can anyone help me out?
> >
> > > Thanks
>
 
LinkBack Thread Tools Display Modes
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
msn messenger not working on vista ultimate Guest Windows Vista 0 02-29-2008 11:56 AM
4gb and vista Ultimate 32bit Rob Windows Vista Hardware & Devices 8 05-19-2007 09:20 AM
Windows Vista Ultimate 32bit? 64bit? Arf_ Windows Vista Hardware & Devices 4 03-01-2007 01:46 PM
MS webcam VX-3000 + Vista Ultimate 32bit = Blue Screen JP Windows Vista Hardware & Devices 0 02-20-2007 06:36 AM
PowerNow not working on my laptop (in Vista 32bit nor 64bit, works fine under WindowsXP) kibusi@vlh.dk Windows Vista Hardware & Devices 5 06-28-2006 03:24 AM