Windows Explorer and remote filesystems ( SMBFS )

Posted: 06-12-2006, 01:26 AM
Hi,

When browsing remote filesystems on the Beta2 of Vista, I notice that not
all folders show up.

I have one directory with 305 subfolders. This hierarchy did show fine in
XP, but in Vista I only get to see 126 folders of the 305 that where
supposed to be available.

What gives ?

( If the question arises then yes, I'm the owner of the directories :-) )

/r

Windows Explorer and remote filesystems ( SMBFS )


Responses to "Windows Explorer and remote filesystems ( SMBFS )"

Michael
Guest
Posts: n/a
 
RE: Windows Explorer and remote filesystems ( SMBFS )
Posted: 06-12-2006, 02:46 AM
Same problem, it doesn't seem to like certain folder names, for remote shares
that is, local folders with the same name appear fine. Also, the "missing"
folders are accessible if you type the location directly into the address
bar. Weird.

Ahh, the joys of beta.

"��r Sigur�sson" wrote:
> Hi,
>
> When browsing remote filesystems on the Beta2 of Vista, I notice that not
> all folders show up.
>
> I have one directory with 305 subfolders. This hierarchy did show fine in
> XP, but in Vista I only get to see 126 folders of the 305 that where
> supposed to be available.
>
> What gives ?
>
> ( If the question arises then yes, I'm the owner of the directories :-) )
>
> /r
>
��r Sigur�sson
Guest
Posts: n/a
 
Re: Windows Explorer and remote filesystems ( SMBFS )
Posted: 06-12-2006, 03:31 AM
I thought so, so I went about and changed the names of all directories
containing anything other than
a-z,A-Z,0-9,_,-

I still only get 126 directories...

Weird :-/

/Thor

"Michael" <Michael@discussions.microsoft.com> wrote in message
news:52F11799-0F1D-4221-BFCE-54691E6AE8B3@microsoft.com...
> Same problem, it doesn't seem to like certain folder names, for remote
> shares
> that is, local folders with the same name appear fine. Also, the "missing"
> folders are accessible if you type the location directly into the address
> bar. Weird.
>
> Ahh, the joys of beta.
>
> "��r Sigur�sson" wrote:
>
>> Hi,
>>
>> When browsing remote filesystems on the Beta2 of Vista, I notice that not
>> all folders show up.
>>
>> I have one directory with 305 subfolders. This hierarchy did show fine in
>> XP, but in Vista I only get to see 126 folders of the 305 that where
>> supposed to be available.
>>
>> What gives ?
>>
>> ( If the question arises then yes, I'm the owner of the directories :-) )
>>
>> /r
>>
Michael
Guest
Posts: n/a
 
Re: Windows Explorer and remote filesystems ( SMBFS )
Posted: 06-12-2006, 10:11 AM
Yeah, on closer inspection it's leaving out a lot of files as well in the
directories it does list.

"��r Sigur�sson" wrote:
> I thought so, so I went about and changed the names of all directories
> containing anything other than
> a-z,A-Z,0-9,_,-
>
> I still only get 126 directories...
>
> Weird :-/
>
> /Thor
>
> "Michael" <Michael@discussions.microsoft.com> wrote in message
> news:52F11799-0F1D-4221-BFCE-54691E6AE8B3@microsoft.com...
> > Same problem, it doesn't seem to like certain folder names, for remote
> > shares
> > that is, local folders with the same name appear fine. Also, the "missing"
> > folders are accessible if you type the location directly into the address
> > bar. Weird.
> >
> > Ahh, the joys of beta.
> >
> > "��r Sigur�sson" wrote:
> >
> >> Hi,
> >>
> >> When browsing remote filesystems on the Beta2 of Vista, I notice that not
> >> all folders show up.
> >>
> >> I have one directory with 305 subfolders. This hierarchy did show fine in
> >> XP, but in Vista I only get to see 126 folders of the 305 that where
> >> supposed to be available.
> >>
> >> What gives ?
> >>
> >> ( If the question arises then yes, I'm the owner of the directories :-) )
> >>
> >> /r
> >>
>
Michael
Guest
Posts: n/a
 
RE: Windows Explorer and remote filesystems ( SMBFS )
Posted: 06-12-2006, 05:08 PM
Looks as tho we're the only ones experiencing this problem...

"��r Sigur�sson" wrote:
> Hi,
>
> When browsing remote filesystems on the Beta2 of Vista, I notice that not
> all folders show up.
>
> I have one directory with 305 subfolders. This hierarchy did show fine in
> XP, but in Vista I only get to see 126 folders of the 305 that where
> supposed to be available.
>
> What gives ?
>
> ( If the question arises then yes, I'm the owner of the directories :-) )
>
> /r
>
Chris Altmann
Guest
Posts: n/a
 
Re: Windows Explorer and remote filesystems ( SMBFS )
Posted: 06-12-2006, 07:39 PM
Sounds like the Samba "Fast Query" problem. What remote server are you
accessing? If it's a server running Samba, you may have to upgrade Samba on
that server. If it's a NAS device that uses Samba internally, you may have
to hope for a firmware upgrade.

If that's not it then I don't know.

http://blogs.msdn.com/oldnewthing/ar...30/564809.aspx
http://blogs.msdn.com/oldnewthing/ar...31/565878.aspx

"??r Sigur?sson" <thor@hugmynda.net> wrote in message
news:45C91E3A-D939-4568-9E9E-C194307F9107@microsoft.com...
> Hi,
>
> When browsing remote filesystems on the Beta2 of Vista, I notice that not
> all folders show up.
>
> I have one directory with 305 subfolders. This hierarchy did show fine in
> XP, but in Vista I only get to see 126 folders of the 305 that where
> supposed to be available.
>
> What gives ?
>
> ( If the question arises then yes, I'm the owner of the directories :-) )
>
> /r
>
Michael
Guest
Posts: n/a
 
Re: Windows Explorer and remote filesystems ( SMBFS )
Posted: 06-12-2006, 09:26 PM
Yup, that was it! Upgraded samba and now all folders/files are listing
correctly.

You rock!

"Chris Altmann" wrote:
> Sounds like the Samba "Fast Query" problem. What remote server are you
> accessing? If it's a server running Samba, you may have to upgrade Samba on
> that server. If it's a NAS device that uses Samba internally, you may have
> to hope for a firmware upgrade.
>
> If that's not it then I don't know.
>
> http://blogs.msdn.com/oldnewthing/ar...30/564809.aspx
> http://blogs.msdn.com/oldnewthing/ar...31/565878.aspx
>
> "??r Sigur?sson" <thor@hugmynda.net> wrote in message
> news:45C91E3A-D939-4568-9E9E-C194307F9107@microsoft.com...
> > Hi,
> >
> > When browsing remote filesystems on the Beta2 of Vista, I notice that not
> > all folders show up.
> >
> > I have one directory with 305 subfolders. This hierarchy did show fine in
> > XP, but in Vista I only get to see 126 folders of the 305 that where
> > supposed to be available.
> >
> > What gives ?
> >
> > ( If the question arises then yes, I'm the owner of the directories :-) )
> >
> > /r
> >
>
chuckofnc
Guest
Posts: n/a
 
RE: Windows Explorer and remote filesystems ( SMBFS )
Posted: 07-06-2006, 01:11 AM
I am experiencing this same problem on a Western Digital Netcenter external
network drive.

Manufacturers website had updated firmware but after installing and flashing
the device the problem is still there.

"��r Sigur�sson" wrote:
> Hi,
>
> When browsing remote filesystems on the Beta2 of Vista, I notice that not
> all folders show up.
>
> I have one directory with 305 subfolders. This hierarchy did show fine in
> XP, but in Vista I only get to see 126 folders of the 305 that where
> supposed to be available.
>
> What gives ?
>
> ( If the question arises then yes, I'm the owner of the directories :-) )
>
> /r
>
 
LinkBack Thread Tools Display Modes
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows explorer heathersgoinnuts Windows Vista File Management 31 04-30-2008 06:19 PM
Disappearing Windows Explorer Fahim Farook Windows Vista File Management 0 09-17-2006 07:35 AM
Remote desktop to windows server 2003 client chrish Windows Vista Networking & Sharing 1 08-21-2006 03:02 AM
Windows Explorer?? HDRDTD Windows Vista File Management 5 07-05-2006 03:08 AM
Windows Explorer Debacle Modsci Windows Vista File Management 3 06-28-2006 03:13 AM