XP SP2 Firewall removed by nLite, broken after SP3 installed

Posted: 03-06-2009, 06:03 PM
On a corporate image, XP's SP2 firewall was disabled with nLite slipstreaming
software. Now, applying SP3 to that image causes the firewall to be
functionally turned back on, but the access to control it is broken. Netsh
will not bring up firewall config, firewall.cpl will not load. Error
encountered "Due to an unidentified problem, Windows cannot display Windows
Firewall settings."

Has anyone encountered this issue, and if so, has anyone found a fix that
doesn't require reinstalling XP? My main objective is to repair the firewall
after it was disabled by nLite prior to applying SP3. I have tried documented
firewall fixes from various support forums without luck.

XP SP2 Firewall removed by nLite, broken after SP3 installed


Responses to "XP SP2 Firewall removed by nLite, broken after SP3 installed"

Anteaus
Guest
Posts: n/a
 
RE: XP SP2 Firewall removed by nLite, broken after SP3 installed
Posted: 03-08-2009, 08:34 PM
Firstly I take it you've checked in services.msc that the firewall service
is running?

If so, check the items on these pages:
http://support.microsoft.com/kb/920074
http://windowsxp.mvps.org/sharedaccess.htm
(Mentions SP2 but I think it should be relevant)

I use nLite quite a lot to remove unneeded stuff from installs, but have
never removed the firewall with it.

"akirchwey" wrote:
> On a corporate image, XP's SP2 firewall was disabled with nLite slipstreaming
> software. Now, applying SP3 to that image causes the firewall to be
> functionally turned back on, but the access to control it is broken. Netsh
> will not bring up firewall config, firewall.cpl will not load. Error
> encountered "Due to an unidentified problem, Windows cannot display Windows
> Firewall settings."
>
> Has anyone encountered this issue, and if so, has anyone found a fix that
> doesn't require reinstalling XP? My main objective is to repair the firewall
> after it was disabled by nLite prior to applying SP3. I have tried documented
> firewall fixes from various support forums without luck.
Alex K.
Guest
Posts: n/a
 
RE: XP SP2 Firewall removed by nLite, broken after SP3 installed
Posted: 03-09-2009, 02:27 PM
Thank you for your reply. Yes, I have tried both of those steps. The
problemis, nLite disables the firewall in a few ways. It removes files
directly related to the service, it alters some other OS files, and it alters
the registry. I have replaced the missing files and updated most of the
modified files along with applying the sharedaccess.reg patch, but this
introduces the issue of Windows system file checker rejecting the installed
version of firewall.cpl.

As to the question of whether the service is running, nLite leaves it in a
state where the ICS/Firewall service doesn't show up in services.msc. After
the SP3 install on top of that, the actual functionality of the service is
restored, but still the ICS/Firewall service does not show up, nor does the
Firewall config tool show up under netsh. It is as if the base level service
is running, but the control layer is still broken. So firewall is
functionally on and blocking all incoming traffic, but there is no way to
bring up the firewall helper panel to modify settings.

Applying the standard firewall install and registry fixes before or after
installing sp3 on top of the nLite-modded XP image does not work. The only
way I have so far been able to turn off the firewall from SP3 is to apply a
differential registry patch based on two identical images with firewall
removed on one, and manually copy all nLite-removed system files. This allows
the firewall to be turned off, but contains a ton of registry entries which
I'm sure are not needed, and it would take me a long time to pare that down
to what's essential.


"Anteaus" wrote:
> Firstly I take it you've checked in services.msc that the firewall service
> is running?
>
> If so, check the items on these pages:
> http://support.microsoft.com/kb/920074
> http://windowsxp.mvps.org/sharedaccess.htm
> (Mentions SP2 but I think it should be relevant)
>
> I use nLite quite a lot to remove unneeded stuff from installs, but have
> never removed the firewall with it.
>
> "akirchwey" wrote:
>
> > On a corporate image, XP's SP2 firewall was disabled with nLite slipstreaming
> > software. Now, applying SP3 to that image causes the firewall to be
> > functionally turned back on, but the access to control it is broken. Netsh
> > will not bring up firewall config, firewall.cpl will not load. Error
> > encountered "Due to an unidentified problem, Windows cannot display Windows
> > Firewall settings."
> >
> > Has anyone encountered this issue, and if so, has anyone found a fix that
> > doesn't require reinstalling XP? My main objective is to repair the firewall
> > after it was disabled by nLite prior to applying SP3. I have tried documented
> > firewall fixes from various support forums without luck.
 
LinkBack Thread Tools Display Modes
 


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual boot prob: XP installed, then HD removed from PC, Win7 installed on diff HD now Guest Windows NT/2000/XP 0 05-15-2009 11:50 AM
Vista Advanced Firewall broken? Daniel Windows Vista Networking & Sharing 1 11-02-2006 02:36 AM
SIP option removed from WM5.1 after MOC installed Yury Windows XP Messenger 0 11-09-2005 06:28 PM
nLite and ram drives for speeding up Virtual PC Carl Mac Virtual PC 5 06-16-2005 05:11 PM
Laptop will not re-boot until extended ram is removed and re-installed kyle Windows XP Hardware 0 03-03-2004 02:26 AM